Adam Bien's Weblog

"Can not execute..." sonar-maven-plugin error and solution

The error after execution of mvn sonar:sonar: "Can not execute SonarQube analysis: Please update sonar-maven-plugin to at least version 2.3" can be fixed by forcing maven to use the recent version in pom.xml


<build>
	<pluginManagement>
		<plugins>
			<plugin>
				<groupId>org.codehaus.mojo</groupId>
				<artifactId>sonar-maven-plugin</artifactId>
				<version>2.5</version>
			</plugin>
		</plugins>
	</pluginManagement>
</build>

The error happens after upgrade to: Sonar 5.0. The Sonar 5.0 requires a >2.3 recent version of the sonar-maven-plugin which does not come as default.


NEW workshop: HTML 5 and JavaScript Essentials, Three days in April 2017: from Java EE 7 Architectures over Microservices to Performance, Troubleshooting and Monitoring
On demand workshops: Java EE 7: Bootstrap, Effective, Testing and Microservices available for streaming.

Newsletter: airhacks.news

A book about rethinking Java EE Patterns

Comments:

Post a Comment:
  • HTML Syntax: NOT allowed
realworldpatterns.com
Online Workshops
...the last 150 posts
...the last 10 comments
License