"Util" packages are evil. The same applies for class naming. The suffix "Util" in class names doesn't provide any useful information. "Util" is an indicator of uncohesive / unrelated contents. e.g. the class name LoggingUtil actually means: "whatever Logging related" -- and it likely becomes a kitchen sink for any logging-related functionality.